Hayward Aquavac 600 Troubleshooting

If you are having problems with your Hayward Aquavac 600 Pool Cleaner, you are not alone. Many Hayward Aquavac 600 owners experience issues with their pool cleaner from time to time, and it can be frustrating to deal with these problems.

I have problems with my Hayward Aquavac 600

Hayward Aquavac 600 Pool Cleaner Problems

Below are common issues and solutions for the Hayward Aquavac 600:

The Hayward Aquavac 600 Lights on PS: No lights

Connect Power Supply to appropriate GFCI Outlet

Cause Solution
  • If connected and still no power
  • Verify that the power outlet works properly
    • GFCI not tripped
    • Main breaker not tripped
    • Try another power outlet
  • If power outlet is ok but still no light on Power Supply
  • Replace Power Supply cord
  • Replace Power Supply

The Hayward Aquavac 600 Lights on PS: Fast flashing blue light

The Power Supply can’t detect or communicate with the cleaner

Cause Solution
  • Floating cable not properly connected to Power Supply
  • Floating cable connection issue with motor box
  • Floating cable is damaged (loss of conductivity)
  • Disconnect and reconnect floating cable to Power Supply
  • Press Pause/Play Button
  • Try to Power Cycle the Power Supply
  • Try to perform a full reset of Power Supply
  • Clean male and female connector pins if corrosion is observed (Use electrical connector cleaner)
  • Floating cable needs to be serviced
  • Motor Box needs to be serviced

The Hayward Aquavac 600 Lights on PS: Fast flashing red light

Cause Solution
  • The cleaner is experiencing an issue that can be resolved by the user, unable to communicate with cleaner after it has established a good connection
  • Cleaner stuck on an obstacle – Relocate the cleaner
  • Drive Motor block – Remove any object or debris from rollers or drive train
  • Pump is blocked – Clean pump and thrust sleeve

The Hayward Aquavac 600 Lights on PS: Medium flashing yellow Light

The Power Supply is overheating (Limp Mode) cleaner is still operating at reduced power

Cause Solution
  • Power Supply is exposed for a long period of time to very
    high temperature or excessive solar load
  • Relocate the Power Supply in a shady or cooler area
  • Let the Power Supply cool down

The Hayward Aquavac 600 Lights on PS: System Fault Detected

System Fault Detected

Cause Solution
  • 3 unresolved consecutive errors
  • Major system malfunction
  • Disconnect the Power Supply
  • Disconnect the cleaner power cord from the Power Supply
  • Reconnect the Power Supply
  • Reconnect the cleaner

The Hayward Aquavac 600 Lights on PS: Slow flashing yellow light

The System is stuck in Bootloader mode

Cause Solution
  • Power Supply does not respond to any action
  • Impossible to established Wi-Fi connection
  • This happened during or just after the Power Supply Firmware Update
  • Power cycle the power supply for 10 secs
  • Go back to your app to complete the update process

The Hayward Aquavac 600 Cleaning the pump and thrust sleeve

Symptoms Cause Solution
  • Flashing Red on Power Supply
  • Cleaner not moving
  • AquaVac Connect App displays Pump error message (AV650 Only)
  • Debris is getting stuck in the shaft/bearings or impeller of the pump (Canister)
  • Remove canister from cleaner
  • Manually, verify that the pump coupling is turning freely by spinning it
  • With your finger, verify that the pump shaft is turning freely
  • Try to start the cleaner (By Pressing the Start button on the PS) without the canister and see if the shaft coupling is turning (Will stop automatically when out of water)
  • Wash the shaft/bearings and impeller  by plunging it up and down in the pool then turn the bottom coupling with your finger until the shaft spins freely
  • Repeat if still not spinning easily

The Hayward Aquavac 600 Reset Wi-Fi connection on mobile device

Cause Solution
  • Go on your mobile device Wi-Fi setting
  • Select AquaVac network
  • Forget the AquaVac network
  • Identify the corresponding Aquavac SSID as shown on label on power supply (AQUAVAC650_XX:XX)
  • Choose the AquaVac Wi-Fi network and enter password (Default: HaywardAVC650 )
  • Wait for connection to be established
  • Go on your mobile device Wi-Fi settings
  • Turn on airplane mode
  • Turn on Wi-Fi
  • Select AquaVac network

The Hayward Aquavac 600 Forgot/Wrong Wi-Fi Password

Cause Solution
  • You forgot or have entered the wrong 13 character password
  • Go on your mobile device Wi-Fi settings
    • Select AquaVac network
    • Forget the AquaVac network
  • Identify the corresponding AquaVac SSID as shown on label on power supply (AQUAVAC650_XX:XX)
    • Choose the AquaVac Wi-Fi network and enter password (Default: HaywardAVC650 )
    • Wait for connection to be established
  • PS Wi-Fi not connected to mobile device
  • Open the Wi-Fi settings on the mobile device
  • Make sure Wi-Fi is enabled
  • Identify the corresponding Aquavac SSID as shown on label on power supply (AQUAVAC650_XX:XX)
  • Choose the AquaVac Wi-Fi network and enter password (Default: HaywardAVC650 )
  • Wait for connection to be established
  • Wi-Fi is off on mobile device
  • Go to your mobile device Wi-Fi settings
  • Turn Wi-Fi on
  • Reconnect to the AquaVac network if not connecting automatically (auto login enabled)
  • Re-initialize comm. with power supply
  • Go to your mobile device Wi-Fi settings
  • Turn Wi-Fi off
  • Turn Wi-Fi on
  • Reconnect to the AquaVac network if not connecting automatically (auto login enabled)

Hayward Aquavac 600 Replacement Parts

How to Diagnose and Repair a Hayward Aquavac 600

This guide will help you identify and resolve issues with your Hayward Aquavac 600 Pool Cleaner.

What to Do If You See Flashing Red on Power Supply and the Cleaner Is Not Moving?

When you encounter a flashing red light on the power supply and the cleaner isn’t moving, or if the AquaVac Connect App shows a pump error message (AV650 only), you may have debris stuck in the pump’s shaft, bearings, or impeller. To resolve this, remove the canister and check that the pump coupling and shaft are turning freely. You can try starting the cleaner without the canister to see if the shaft coupling turns. If it’s not spinning easily, wash the shaft, bearings, and impeller by moving it up and down in the pool water and manually turning the bottom coupling until it spins freely. Repeat the process if necessary.

How to Reset Wi-Fi Connection on Mobile Device for Hayward Aquavac 600?

If you need to reset the Wi-Fi connection on your mobile device for the Hayward Aquavac 600, go to your device’s Wi-Fi settings, select the AquaVac network, and choose to forget the network. Then, identify the corresponding AquaVac SSID on the power supply label (AQUAVAC650_XX), select the AquaVac Wi-Fi network, and enter the default password (HaywardAVC650). Wait for the connection to be established. If you’re still having trouble, try enabling airplane mode and then turning Wi-Fi back on to select the AquaVac network again.

What to Do If You Forgot or Entered the Wrong Wi-Fi Password for Hayward Aquavac 600?

In case you forgot or entered the wrong Wi-Fi password for your Hayward Aquavac 600, go to your mobile device’s Wi-Fi settings, forget the AquaVac network, and then reconnect using the correct SSID and password as shown on the power supply label. The default password is HaywardAVC650. Wait for the connection to be established.

How to Connect Hayward Aquavac 600 to Mobile Device If PS Wi-Fi Is Not Connected?

To connect your Hayward Aquavac 600 to a mobile device when the PS Wi-Fi is not connected, open the Wi-Fi settings on your device, make sure Wi-Fi is enabled, and connect to the correct AquaVac network using the default password. If the Wi-Fi is off on your mobile device, turn it on and reconnect to the AquaVac network, ensuring that auto-login is enabled. If needed, toggle Wi-Fi off and on again to reinitialize communication with the power supply.

Hayward Aquavac 600 Pool Cleaner Troubleshooting

Share your Hayward Aquavac 600 Pool Cleaner Problems, issues , tips, ideas, and frustrations with other owners.

  1. What are common issues with the 600 if it randomly has started turning over, going to corners and stopping and overall not completing a full clean cycle? A new behavior.

    1
    Reply
  2. Our vacuum keeps going in circles. We reset it and it still won’t work correctly. What else can I do?

    5
    Reply
  3. Lights seem fine. They are green.
    Seems like there isn’t any bubbles or moment out of the top vent anymore. Not sure if anything is working when I press the bottoms to start.

    Reply

Hayward Aquavac 600 Issues? Need Help?

Users are encouraged to share their tips or frustrations with their Hayward Aquavac 600 with the community by leaving a comment. Sharing insights and experiences can help other users get the most out of their pool cleaner and avoid common issues.

Share your Thoughts or Describe your problem below:

The maximum upload file size: 5 MB. You can upload: image. Links to YouTube, Facebook, Twitter and other services inserted in the comment text will be automatically embedded. Drop files here

Ask a Hayward Aquavac 600 Question

If you're facing a particular issue with your Hayward Aquavac 600 and need assistance, feel free to ask your question here.

Submit Question

Related Pool Cleaner Problems